Translation Tools

Descripción

Usa cualquier configuración regional, con o sin paquetes de idioma

Con los paquetes de idioma del núcleo, puedes cambiar fácilmente el idioma de tu instalación de WordPress.

Los paquetes de idiomas solo se suelen proporcionar para configuraciones regionales traducidas al 100 %.

Para dar a los equipos con menos colaboradores una mejor oportunidad de conseguir que WordPress se publique en su configuración regional, desde el 22 de febrero de 2021, el estado de la traducción necesario para que se creen los paquetes de idioma para el núcleo es el siguiente:

Si necesitas una configuración regional que aún no tiene paquetes de idioma, esta herramienta te ayuda a activar TODAS las configuraciones regionales en la lista de idiomas disponibles.

Compatibilidad con el plugin Preferred Languages

El plugin Preferred Languages anula el campo de idiomas estándar para los idiomas del sitio y del usuario.

Todas las características añadidas por Translation Tools están disponibles para los usuarios de Preferred Languages.

Actualiza la traducción de WordPress, de los plugins y de los temas bajo demanda

Si necesitas actualizar bajo demanda tu traducción del núcleo de WordPress, de plugins o de temas sin esperar a que sea generado un paquete de idioma, esta herramienta te permite actualizar manualmente todos los archivos necesarios para la versión instalada, con un solo clic, en unos segundos.

Ve a «Traducciones» en la pantalla de actualizaciones y elige lo que quieres actualizar.

Todos los subproyectos del núcleo de WordPress

  • Desarrollo
  • Continentes y ciudades
  • Administración
  • Administración de la red

Todos los archivos de traducción

  • .po (archivos editables de traducción)
  • .mo (archivos de traducción binarios)
  • .json (archivos JavaScript de traducción)

Pruebas e información de las traducciones de WordPress en la salud del sitio

Comprueba tus traducciones del núcleo de WordPress en la página de pruebas de la salud del sitio.

La información de depuración de la salud del sitio muestra los idiomas seleccionados del sitio y del usuario, incluyendo varios idiomas del plugin Preferred Languages.

Capturas

  • Los ajustes de idioma incluyen configuraciones regionales SIN paquetes de idioma
  • Botón para actualizar la traducción de WordPress bajo demanda
  • Traducciones de todos los subproyectos del núcleo
  • Detalles y archivos de los subproyectos
  • Avisos de actualizaciones de traducciones de temas y plugins para configuraciones regionales sin paquetes de idioma
  • Actualización automática de la traducción de temas para configuraciones regionales sin paquetes de idiomas
  • Recomendación de la prueba de salud del sitio para una traducción incompleta de WordPress
  • Prueba de salud del sitio aprobada para una traducción completa de WordPress
  • Información de depuración de la salud del sitio para las traducciones de WordPress del sitio y del usuario, compatible con Preferred Languages

FAQ

¿Dónde puedo encontrar la lista completa de las configuraciones regionales de WordPress?

Aquí está la lista completa de todas las configuraciones regionales de WordPress.

¿Mi configuración regional tiene paquetes de idioma?

Aquí hay una lista de las configuraciones regionales CON paquetes de idioma.
Aquí hay una lista de las configuraciones regionales SIN paquetes de idioma.

Mi configuración regional tiene paquetes de idioma, pero la traducción no está completa

Puedes forzar la actualización de la traducción de WordPress directamente desde la pantalla «Escritorio > Actualizaciones».
Haz clic en «Actualizar la traducción de WordPress» y listo.
En unos segundos se generarán todos los archivos de traducción necesarios (.po, .mo y .json).

No puedo usar mi idioma en WordPress, temas o plugins porque la configuración regional no tiene paquetes de idioma

¡Ahora puedes! Simplemente instala y activa este plugin para activar todas las posibles configuraciones regionales y traducciones.

La configuración regional que quiero no existe en la lista

Si tu configuración regional no existe y te gustaría solicitarla, por favor, haz clic aquí.

¿Puedo actualizar también las traducciones de los plugins y temas?

Sí, puedes, desde la versión 1.5.0.
En la página de actualizaciones, puedes elegir actualizar las traducciones de WordPress, de los plugins, de los temas o de todo a la vez.
Actualizará los archivos «.po» y «.mo» y también generará los archivos «.json» necesarios para las traducciones de JavaScript.

¿Este plugin es compatible con el plugin Preferred Languages?

Respuesta corta: ¡sí!

El plugin Preferred Languages anula el campo de idiomas estándar para los idiomas del sitio y del usuario.

Desde la versión 1.2.0, este plugin es compatible con Preferred Languages ​​1.6.0.

Todas las características añadidas por Translation Tools están disponibles para los usuarios de Preferred Languages.

¿Puedo ayudar a traducir este plugin a mi propio idioma?

¡Sí, puedes! Si quieres traducir este plugin a tu idioma, por favor, haz clic aquí.

¿Puedo colaborar con este plugin?

¡Por supuesto! Puedes informar de cualquier problema o añadir sugerencias de características en el repositorio de GitHub.

Reseñas

10 de agosto de 2020
A fundamental tool for translators (and not only), works flawlessly.
Leer la 1 reseña

Colaboradores y desarrolladores

«Translation Tools» es un software de código abierto. Las siguientes personas han colaborado con este plugin.

Colaboradores

«Translation Tools» ha sido traducido a 13 idiomas locales. Gracias a los traductores por sus contribuciones.

Traduce «Translation Tools» a tu idioma.

¿Interesado en el desarrollo?

Revisa el código , echa un vistazo al repositorio SVN o suscríbete al registro de desarrollo por RSS.

Registro de cambios

1.5.3

  • Mejores mensajes de los informes sobre las actualizaciones de los proyectos de traducción
  • Aumento del tiempo de espera de las descargas para conexiones de baja velocidad
  • Nuevo filtro para personalizar el tiempo de espera de las descargas para grandes proyectos de traducción en conexiones de baja velocidad
  • Optimización del proceso de lanzamiento de GitHub

1.5.2

  • Corrección de un problema con i18n
  • Aumento del tiempo de espera de las descargas para conexiones de baja velocidad
  • Optimización del proceso de lanzamiento de GitHub

1.5.1

  • Añadidos los archivos de vendedores que faltaban

1.5.0

  • ¡Actualiza las traducciones de tus plugins y temas! (archivos «.po», «.mo» y «.json»)
  • La acción de actualización ahora se carga en una página personalizada dedicada de actualización del núcleo
  • Reprogramación del código para ampliar la actualización de los archivos «.po/.mo/.json» para los plugins y temas
  • Informes detallados sobre las actualizaciones de los proyectos de traducción
  • Nuevo filtro para personalizar/invertir la prioridad de los proyectos de traducción de los plugins de WP.org (por defecto, «Stable» y «Development»)
  • Nuevo filtro para personalizar las traducciones de los plugins y temas a actualizar
  • Nuevo filtro para desactivar la descarga de las traducciones y generar los archivos «.json» a partir de tus actuales archivos «.po»
  • Nuevo filtro para desactivar la actualización de los archivos «.json» de las traducciones de JavaScript
  • Optimización del proceso de lanzamiento de GitHub
  • Optimización de las carpetas de recursos
  • Mejoras en el modo de depuración

1.4.1

  • Mejorada la redacción de los avisos sobre la disponibilidad de los paquetes de idioma
  • Corregida la accesibilidad de los enlaces de los avisos

1.4.0

  • Probado hasta WP 5.8
  • ¡Más pruebas de las traducciones de la salud del sitio de WordPress!
  • Probada la salud del sitio para comprobar si la API de traducción de WordPress está disponible desde tu sitio
  • Probada la salud del sitio para informar si tu versión de WordPress ya está disponible para traducir. Es útil para pruebas beta
  • Reprogramar las pruebas de la salud del sitio para permitir la dependencia entre pruebas (por ejemplo, ejecutar una prueba solo si otra prueba tiene el estado «bueno»)
  • Ahora, las pruebas de traducción de la salud del sitio tienen el color rosa de #WPPolyglots para usabilidad
  • Nuevo aviso de advertencia en la pantalla de actualizaciones cuando tu versión de WordPress aún no está disponible para traducir. Es útil para pruebas beta
  • Ahora, forzar la comprobación en la pantalla de actualizaciones (`force-check`), fuerza las actualizaciones de los datos de traducción del núcleo de WordPress
  • Ahora, los datos transitorios de la traducción del núcleo de WordPress caducan en 1 hora
  • Corregido un problema con el ID del informe «Más detalles» al descargar los proyectos de traducción de las configuraciones regionales

1.3.3

  • Probado hasta WP 5.7
  • Corregido el mensaje i18n de la salud del sitio

1.3.2

  • Probado hasta WP 5.6
  • Mejoras menores del código

1.3.1

  • Corregido un problema con la configuración regional «en_US» en los idiomas del usuario en los ajustes de Preferred Languages

1.3.0

  • ¡Nuevas pruebas de traducción de la salud del sitio de WordPress e información de depuración!
  • Pruebas de salud del sitio para mostrar el estado actual de los paquetes de idioma para los idiomas de tu sitio y del usuario para tu versión instalada de WordPress
  • La información de depuración de la salud del sitio incluye detalles sobre el idioma de tu sitio y del usuario
  • Las pruebas de la salud del sitio y la información de depuración son compatibles con varios idiomas configurados en el plugin Preferred Languages
  • Inspirado por el tique #51039 (WIP)

1.2.4

  • Corregido un problema con cadenas faltantes en los archivos «.json», causado por la anulación de los archivos «.json» de los subproyectos de desarrollo y administración del núcleo, en lugar de fusionar ambos.
  • Basado en el conjunto de cambios #10064 de meta

1.2.3

  • Nuevo filtro translation_tools_get_wp_translations_status para personalizar el estado de las cadenas a descargar
  • Nuevo filtro translation_tools_show_locale_codes para añadir los códigos de la configuración regional a cada idioma
  • Nuevo filtro translation_tools_show_locale_colors para resaltar las configuraciones regionales sin paquetes de idioma
  • Nuevo filtro translation_tools_translate_url para anular translate.w.org/projects/wp/ con una instalación privada de GlotPress con la misma estructura exacta del núcleo de WP
  • Renombrado el filtro ttools_get_wp_translations_status como translation_tools_get_wp_translations_status
  • Compatible con el campo de selección de idioma del plugin Translation Stats
  • Optimización del código

1.2.2

  • Nuevo filtro ttools_get_wp_translations_status para personalizar las cadenas filtradas para descargar, por defecto es «current»
  • Corregida la compatibilidad para las versiones beta del núcleo
  • Mejorados los datos del núcleo de los subproyectos de traducción a través de la API de translate.wp.org
  • Probado hasta WP 5.5
  • Mejoras menores del código

1.2.1

  • Corregida la cabecera no válida del plugin al activarlo

1.2.0

1.1.0

  • Mejorada la usabilidad y eliminados los pasos adicionales para añadir configuraciones regionales sin paquetes de idioma
  • Eliminado el ajuste del plugin para añadir de forma previa una configuración regional a la lista principal. Ahora, todos los idiomas existentes están disponibles inmediatamente
  • Los ajustes de idioma ahora incluyen todas las configuraciones regionales, agrupadas por el estado de los paquetes de idioma
  • Ahora, los ajustes del idioma están disponibles para el sitio (pantalla de ajustes generales) y para los usuarios (pantallas de edición del perfil y del usuario)
  • Renombrados los idiomas adicionales disponibles al formato «Nombre nativo [wp_locale]», en lugar de solo «wp_locale»
  • Enlace para actualizar la traducción de WordPress de la descripción de los ajustes del idioma del sitio, del perfil y del usuario
  • Respaldo de actualización de la configuración regional del núcleo a «en_US» para configuraciones regionales sin paquetes de idioma
  • Mejoras menores del código

1.0.1

  • Mejorada la información mostrada cuando aún no hay ajustes
  • Mejorada la información mostrada cuando no hay configuraciones regionales sin paquetes de idioma
  • Mejorada la información mostrada cuando no se puede acceder a la API de translate.wp.org
  • Mejoras menores del código

1.0.0

  • Versión inicial.